www.der-Sauerteig.de Foren-Übersicht www.der-Sauerteig.de
Der Sauerteig - das unbekannte Wesen
 
Die Leser unseres Forums stammen aus allen Ländern und gesellschaftlichen
Hintergründen. Sie haben verschiedene Weltanschauungen und Religionen. Es ist
selbstverständlich für uns, dass dieses Forum völkerverbindend und mitmenschlich ist.
Radikale und menschenverachtende Ansichten werden wir deshalb nicht dulden.

 FAQFAQ   IMPRESSUMImpressum   SuchenSuchen   MitgliederlisteMitgliederliste   RegistrierenRegistrieren 
 ProfilProfil   Einloggen, um private Nachrichten zu lesenEinloggen, um private Nachrichten zu lesen   LoginLogin 
 Intro   Portal 
isaak naturkost-Versand hat für Sie französisches Biomehl!
Bio-T45 für Feingebäck (Madeleine, Croissant, Brioche etc)
und Bio-T65 für echte Baguettes
 
www.der-Sauerteig.de auf Facebook teilen
ICH BRAUCHE HILFE!

 
Neues Thema eröffnen   Neue Antwort erstellen    www.der-Sauerteig.de Foren-Übersicht -> Offtopic
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Pöt
Administrator
Administrator


Anmeldungsdatum: 03.09.2004
Beiträge: 3306

BeitragVerfasst am: 25.07.2018, 10:34    Titel: ICH BRAUCHE HILFE! Antworten mit Zitat

Hallo zusammen,

wie wir alle sehen, haben wir nach wie vor Probleme mit den Umlauten.

Entstanden ist es nach einem Update der php-Version, dass die alte Datenbank (mysql) nicht mehr sauber angesprochen werden konnte.

Ich habe daraufhin eine andere DB installiert (MariaDB), die eigentlich 100% kompatibel ist.

Trotzdem laufen die Umlaute nicht sauber im Script. In der DB stehen sie aber richtig drin.

Ich selbst komme aus diversen Gr?nden nicht zur Loesung. Auch zeitlich.

Ich benoetige deshalb hier Hilfe von jemand der sich einigerma?en mit Datenbanken und php auskennt. Ich bin fest der Meinung, es ist nur ein kleines Schalterchen, der falsch gesetzt ist.

Wer kann mir helfen? Es wird auch monitaer honoriert.

Kontaktaufnahme bitte unter

Stoldt@Stoldt-it.de
bzw
http://www.Stoldt-it.de

Herzlichen Dank!

Poet
_________________
Habe die Ähre!

Pöt

Bitte keine Hilfeanfragen zu Sauerteig oder Rezepten
per PM, KM oder I-Mehl stellen! Dafür ist das Forum da!

_______________

Mein Blog, mein Shop, mein Buch!
FreelancerIT-Dienstleistung .
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Google






Verfasst am:     Titel: Anzeige

Nach oben
Hobbykoch17
Profi im Sauerteigbacken
Profi im Sauerteigbacken


Anmeldungsdatum: 15.09.2014
Beiträge: 926
Wohnort: AT-Ost

BeitragVerfasst am: 26.07.2018, 08:30    Titel: Antworten mit Zitat

@ Juergen: ich hab' Poet mal per Mail Deine/unsere Erkenntnisse die Textcodierung im Header betreffend mitgeteilt.

LG
Reinhard
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
JuergenPB
Sauerteigfachmann
Sauerteigfachmann


Anmeldungsdatum: 12.05.2016
Beiträge: 380

BeitragVerfasst am: 26.07.2018, 14:05    Titel: Antworten mit Zitat

Hobbykoch17 hat Folgendes geschrieben:
@ Juergen: ich hab' Poet mal per Mail Deine/unsere Erkenntnisse die Textcodierung im Header betreffend mitgeteilt.
Das ist sehr loeblich. Smilie

Ich bin mir aber nicht sicher, ob das das Problem loest, oder ob da nicht doch noch eine andere Einstellung in der Datenbank notwendig ist.

Weitere Moeglichkeiten:

In der Server Konfiguration (Apache-Config-Datei) oder alternativ in der .htaccess-Datei die Direktive AddDefaultCharset nutzen, um auf utf-8 umzuschalten
Code:
AddDefaultCharset utf-8


Falls der Provider das nicht zulaesst, per PHP umschalten:
Code:
<?php
header("Content-Type: text/html; charset=utf-8");
?>


Derzeit liefert der Server naemlich, soweit ich sehe, nicht:
Code:
Content-Type: text/html; charset=utf-8

sondern nur:
Code:
Content-Type: text/html

_________________
Gruß
Jürgen
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Pöt
Administrator
Administrator


Anmeldungsdatum: 03.09.2004
Beiträge: 3306

BeitragVerfasst am: 27.07.2018, 11:22    Titel: Antworten mit Zitat

test
äöüÄÖÜß
_________________
Habe die Ähre!

Pöt

Bitte keine Hilfeanfragen zu Sauerteig oder Rezepten
per PM, KM oder I-Mehl stellen! Dafür ist das Forum da!

_______________

Mein Blog, mein Shop, mein Buch!
FreelancerIT-Dienstleistung .
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Pöt
Administrator
Administrator


Anmeldungsdatum: 03.09.2004
Beiträge: 3306

BeitragVerfasst am: 27.07.2018, 11:39    Titel: Antworten mit Zitat

Also, der Fehler ist erheblich tiefer, liegt zum Teil an dem neuen php, an der php.ini, an der Codierung in der DB und letztendlich an den vorgefertigten TExten des Templates.

Ich habe jetzt einfach mal die Seitencodierung auf UTF-8 gesetzt. So sind die DB-Inhalte ok, das Posten funktioniert, nur die (äußere) Foren-Optik hat ein Umlaut-Problem. Ist jetzt die kleinere Baustelle...

Ich werde es jetzt vorerst so lassen und schauen, dass ich schnellstmöglich ein neues Forum mit alten DB-Inhalten aufbaue.

Nochmals vielen Dank und schöne Grüße an alle!

Pöt
_________________
Habe die Ähre!

Pöt

Bitte keine Hilfeanfragen zu Sauerteig oder Rezepten
per PM, KM oder I-Mehl stellen! Dafür ist das Forum da!

_______________

Mein Blog, mein Shop, mein Buch!
FreelancerIT-Dienstleistung .
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
VolkerC
Sauerteigfachmann
Sauerteigfachmann


Anmeldungsdatum: 15.10.2012
Beiträge: 177
Wohnort: Umgebung Frankfurt

BeitragVerfasst am: 27.07.2018, 12:14    Titel: Antworten mit Zitat

Hallo Pöt,

wenn Du die Texte des Portals nicht mit Umlauten, sondern mit HTML Symbolen wie &auml für "ä" schreibst, werden die korrekt angezeigt und die bist die Problematik mit der Darstellung los.

Es bleibt aber noch das Problem, dass an einigen Stellen die Uhrzeit in HH:SS statt HH:MM angezeigt wird. Also die Sekunden statt der Minuten.
_________________
Liebe Grüße und viel Erfolg beim Backen,
Volker
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
JuergenPB
Sauerteigfachmann
Sauerteigfachmann


Anmeldungsdatum: 12.05.2016
Beiträge: 380

BeitragVerfasst am: 27.07.2018, 17:13    Titel: Antworten mit Zitat

Gut, daß es jetzt funktioniert.


Der Rest ist eher Kosmetik.
Eine Fehlerquelle könnte möglicherweise im falschen Abspeichern von Textdateien zu finden sein.
Alle Dateien müssen im UTF-8 Format abgespeichert sein. Das betrifft natürlich auch die Template-Dateien.
Hat man eine Mischung in den Textformaten, gibt es Probleme.
_________________
Gruß
Jürgen
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
flieger-lupo
Anfänger, der sich noch umschaut
Anfänger, der sich noch umschaut


Anmeldungsdatum: 04.11.2015
Beiträge: 3

BeitragVerfasst am: 27.07.2018, 18:59    Titel: Darstellung im Firefox Antworten mit Zitat

Moin,

es scheint noch ein anderes Problem zu geben: Im Firefox, hier Vers. 61.0.1 64 bit, bekomme ich nichts angezeigt, nur im IE Version 11.

Ich habe dazu einen Screenshot angefertigt, kann ich gerne zuschicken.

Gruss

Lupo
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Pöt
Administrator
Administrator


Anmeldungsdatum: 03.09.2004
Beiträge: 3306

BeitragVerfasst am: 30.07.2018, 11:19    Titel: Antworten mit Zitat

Ich bin gerade mit FF 61.0.1 (64-Bit) unter Win 10 pro drin und sehe alles und kann (qed) auch schreiben.

Kannst Du mal den Cache leeren und dann nochmals probieren?
Danke!
_________________
Habe die Ähre!

Pöt

Bitte keine Hilfeanfragen zu Sauerteig oder Rezepten
per PM, KM oder I-Mehl stellen! Dafür ist das Forum da!

_______________

Mein Blog, mein Shop, mein Buch!
FreelancerIT-Dienstleistung .
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
flieger-lupo
Anfänger, der sich noch umschaut
Anfänger, der sich noch umschaut


Anmeldungsdatum: 04.11.2015
Beiträge: 3

BeitragVerfasst am: 30.07.2018, 12:14    Titel: Antworten mit Zitat

Habe ich geleert und wird auch beim Schliessen des Firefox automatisch geleert.

Das Problem zeigt sich inzwischen wie folgt:
Aufbau Teaser, 2-3 Min Wartezeit, dann kommt der Rest. In der Statuszeile unten wird relativ lange auf Datenübetragung gewartet. Kann an der Datenleitung oder dem Server liegen, das kann ich von hier nicht sehen.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    www.der-Sauerteig.de Foren-Übersicht -> Offtopic Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.

Neue Synagoge Ulm


 Intro   Portal 
Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de
-PH1- -PH2-

<-ST-IT->